最新通达信主图指标 通达信MACD买点副图公式


 

综投网()3月18日讯

DIFF:EMA(CLOSE,10)-EMA(CLOSE,22);

DEA:EMA(DIFF,5),COLORFFAA00;

MACD:=2*(DIFF-DEA);

STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,4,1),colorwhite;

STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,4,0 ),COLOR00AAFF;

X1:IF(DIFF<0,DIFF,0),COLOR0000FF,LINETHICK2;

X2:IF(DIFF<0,0,DIFF),colormagenta,LINETHICK1;

X3:IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

X4:IF(DIFF>DEA,DEA,DEA),LINETHICK1,COLORFFBB11;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;

DRAWTEXT(低位金叉,DEA*0.86,' 低'),coloryellow;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*1.1,'BUY') ;

DRAWTEXT(二次金叉,DEA*0.96,' 二叉'),COLORFF3300;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),COLOR00FF00;

DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,LINETHICK1;

DRAWTEXT(底背离,DEA*1.09,' 底'),COLORDD22FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,LINETHICK1;

DRAWTEXT(顶背离,DEA*1.02,' 顶'),COLOR00FF00;

游戏体育

内容版权声明:内容均来自于网络,如有侵权行为请发送邮件至3530594566@qq.com,我们将在第一时间删除